Degraded Performance on US - 2
Incident Report for Humio
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 05:58 UTC
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 03:08 UTC