Degraded performance on US cloud
Incident Report for Humio
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 20:53 UTC
Investigating
We are currently investigating this issue.
Posted Apr 02, 2024 - 15:52 UTC
This incident affected: US (Searching).